Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have several Fedora 13 servers that have to connect through an http proxy for yum updates. All port 80 traffic has to be routed through this proxy. I have setup the proxy server in the network settings GUI. I can browse the internet just fine. I have also setup my proxy information in /etc/yum.conf as follows: proxy=http:proxy.largecorp.corp/accelerated_pac_base.pac proxy_user=user proxy_password=password

I then added the export HTTP_PROXY="http:proxy.largecorp.corp/accelerated_pac_base.pac" to /etc/bashrc and sourced the file.

When i run yum update: Loaded plugins:presto, refresh-packagekit Error: Cannot retrieve repository metadata (repomd.xml) fro repository: fedora. Please verify its path and try again.

All of the repo urls are the defaults, as this is a fresh install.

share|improve this question

2 Answers 2

Use ntlmaps proxy. http://sourceforge.net/projects/ntlmaps/ configure it, run it (you need python on your box) and put something like

http://127.0.0.1:5865 

in your yum.conf (port number may be different, depending on your configuration).

share|improve this answer

http:proxy.largecorp.corp/accelerated_pac_base.pac is not a valid URL, shouldn't it be http://proxy.largecorp.corp/accelerated_pac_base.pac?

Apart from this, you should try to explicitely state which proxy yum needs to use, instead of pointing it to an auto-configuration URL like the one you're using; something like

http://proxy.largecorp.corp:8080

Just look up your actual proxy settings and use them.

share|improve this answer
    
That was a typo on my part. –  eodchop Jun 3 '10 at 12:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.