Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've had this problem for a few months now. I thought it started when I installed the Traveller software on the server to add ActiveSync support, but I removed that and the problem still persists.

Basically new instances of "nchronos.exe" keeps spawning (and not ending), so over a period of a few days the server eventually gets drowned in nchronos.exe processes, stops responding and I need to kill Domino. My process count the last time was up at about 330, and when I killed it and restarted the Domino my process count went to 160.

I'm running Domino 8.5.1 with Fix Pack 2.

I don't know if it's relevant, but my Domino server was also acting as a Sametime server. At around the same time that nchronos started playing up sametime also stopped working. None of my users can connect to sametime and in the domino log it keeps telling me "stpolicy.exe" has terminated. I've googled for that and tried a few things, but nothing seems to make sametime work again.

Any thoughts??

Cheers, Kevin

share|improve this question

2 Answers 2

nchronos is forking a reindex and the db that its indexing is bad, you can crank up the log level if needed. Temporarily set choronos to daily not hourly.

share|improve this answer
    
Thanks for that. From what you said I found another page that helped me out (www-01.ibm.com/support/…). Based on that I added to notes.ini: DEBUG_THREADID=1 DEBUG_SHOW_TIMEOUT=1 DEBUG_CAPTURE_TIMEOUT=1 That was meant to help me diagnose the problem, but in fact it seems to have fixed it. I had the server running over the weekend and there's no nchronos processes running at the moment. I'm not sure why this seems to have fixed it. Does it make sense to you? Would it be safe to keep those there? –  Kevin Jun 7 '10 at 13:10
    
do you run db maintenance on the weekends? If so that might have fixed things. –  tony roth Jun 7 '10 at 14:01

@tony NCRONOS only runs hourly.

Also only one NCRONOS should run at any given time. It is possible that it is not completing in time.

The ini setting DEBUG_DISABLE_CHRONOS=1 will allow you to disable it, although there are implications in doing so. Following tech note details more:

https://www-304.ibm.com/support/docview.wss?uid=swg21298543

Debugging NCRONOS issues the following debug might help:

DEBUG_THREADID=1
DEBUG_NIF=2
DEBUG_FTV_INDEX=1
CONSOLE_LOG_ENABLED=1

Then match the debug output with the thread ID related to the Cronos task. Logs will be stored in the IBM_TECHNICAL_SUPPORT folder.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.