Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I used a turnkeylinux.org otrs installation and I'm trying to configure the default domain of 'yourhost.example.com'. I tried the following:

sed -ri 's/yourhost.example.com/mydomain.com/' /usr/share/otrs/Kernel/Config/Defaults.pm
sudo shutdown -r now 

The next time I logged and tried to create a user, the default domain was still there.

How can I change default doamin in an OTRS installation?

share|improve this question
    
Maybe there's a config.pm file to modify ? Did you try greping in all the files (grep -r "yourhost" /usr/share/otrs/Kernel/Config/). –  Maxwell Jun 3 '10 at 16:01
    
Well I suppose I could do: find /usr/share/otrs/ -type f -exec sed -ri 's/yourhost.example.com/mydomain.com/' {} \; ... buuuut I was hoping someone could point me to how to do it through the interface (as a best practice) –  Jamie Jun 3 '10 at 17:41

1 Answer 1

up vote 0 down vote accepted

you should modify /etc/otrs/Kernel/Config.pm - the guys at turnkeylinux are using the default Debian OTRS package.

Please read /usr/share/doc/otrs2/README.Debian for instructions on how to make the permissions a little less paranoid so you can leverage the Package Manager and the SysConfig, two powerful OTRS features.

So are you using the new Turnkey images based on Ubuntu Lucid? Which means you have OTRS 2.4.7?

-- Mike.

share|improve this answer
    
The Turnkey distro I'm using is based on Hardy Heron. –  Jamie Jun 4 '10 at 14:12
    
Which means you're testing out a real old version of OTRS: 2.2.x or so. Please just get the latest OTRS version from otrs.org/download instead. –  MichielB Jun 8 '10 at 7:26
    
That's your solution: upgrade? –  Jamie Jun 9 '10 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.