Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How to disable the Reconnect at logon setting for a mapped network drive on Vista? How to disconnect already mapped drives?

share|improve this question
    
Are you wanting to do this as a once off, or as a task via SMS or something on your network for all users? –  RobertTheGrey Apr 30 '09 at 19:28
    
I want just to turn it off for a specific mapping. –  Toro Apr 30 '09 at 21:17
add comment

closed as off topic by sysadmin1138 Jul 10 '11 at 23:28

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

up vote 4 down vote accepted

to disconnect, use:

net use Z: /d

Windows will not try to re-connect the drive when logging on again (unless the drive is actually being connected in a logon script or similar, of course).

share|improve this answer
add comment

NET USE /PERSISTENT:NO will turn off persistence for future network mappings. If you already have the mapping, you need to delete it and recreate it after to change the setting.

share|improve this answer
    
Works patially: persistence is OFF for future mappings, but I'm not able to kill my existing mapping... –  Toro May 2 '09 at 14:24
add comment

You'll need to first disconnect from the server, then map it again to change it.

share|improve this answer
    
It doesn't work, when I log off and log on again I still have a mapped drive, –  Toro May 2 '09 at 14:22
    
my experience so far is also that this procedure is not sufficient; i end up with the drive still mapping automatically. –  hakamadare Jul 15 '10 at 15:08
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.