Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I type in the standard web address for my site, I get a 403 error. However, when I type in a more exact address, say pointing to an index.php file, everything shows up fine.

I'm using Anodyne Productions' Nova (SMS 3) which uses codeignitor. All accompanying software (PHP/MySQL) is compatible.

I'm not a very technical person, so I'm hoping that this is an easy fix.

Thanks for taking the time to answer.

share|improve this question
add comment

3 Answers

Thanks for the tip. I ultimately dealt with the issue by setting up a redirect in CPanel.

share|improve this answer
add comment

CodeIgniter uses the Front-Conroller pattern, which means all requests are marshalled through a single controller, in this case index.php

If you don't want that to show up in the URL, you need to setup up rewrites on your server.

The CodeIgniter Wiki has a pretty comprehensive explanation.

share|improve this answer
add comment

By using mod_rewrite, the "redirection" is done automatically and removes the index.php from the url, it's easier than handling everything manually through the cPanel really.

I'm running a CodeIgniter website myself on my server and it's working perfectly, read this

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.