Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm encountering a problem on a sever with two ethernet interfaces(etho and eth1), it runs linux-ubuntu-server. I need eth1 not make any dhcp request, becouse I need it to be only a listening interface, obviusly I need eth0 running normally. So how can i disable any dhcpclient ation over eth1?

thank in advance.

share|improve this question

migrated from stackoverflow.com Jun 5 '10 at 6:17

This question came from our site for professional and enthusiast programmers.

1 Answer 1

Something like:

auto lo eth0 eth1

iface lo inet loopback

iface eth1 inet static
        address 192.168.32.130
        netmask 255.255.255.0
        gateway 192.168.32.1

in your /etc/network/interfaces config file will assign your eth1 a static IP address.

share|improve this answer
    
I need eth1 to be mute, no IP at all, probably i could set in /etc/network/interfaces address to 0.0.0.0 –  Lopoc Jun 4 '10 at 9:15
2  
@Lopoc: If you want eth1 to be disabled completely, you may try to leave only interfaces you need to be up in /etc/network/interfaces: auto lo eth0. If you want your interface to reject all incoming connections you may use iptables, ipfw. –  Yasir Arsanukaev Jun 4 '10 at 9:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.