Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a small home server using Fedora 13 as operating system.

Since the upgrade to Fedora 13 I cannot start the X11 server. (I need it to use vnc)

When I try to start the server, both the nouveau and the original NVIDIA driver claim that there's no physical monitor attached (which is true) and that the X server cannot start because the initial display modes cannot be probed.

I tried to manually add the display modes to xorg.conf but they seem to be ignored.

Some forums suggest to simply use the VESA driver in this situation, but since I can't get it run either (different, more obscure message) I want to get it working with the nouveau driver as a matter of principle.

Temporarily attaching a monitor would mean a lot of work for me (> 1 hour and currently it's almost 35°C/95°F in my home) I want to try that only if that definitely fixes the problem and stays that way if I remove the monitor again)

How can I make the driver work without having a physical monitor attached?

Thank you for your time and your help!

share|improve this question
add comment

4 Answers

One option would be to set up X forwarding over ssh and run an X server on your local machine with the apps running on the server.

share|improve this answer
    
+1 Until now I didn't knew there was a free Windows X server and never got the Cygwin one to work. XMing works flawlessly and out of the box. But I don't accept your answer, because it only circumvents the original problems. Many thanks nevertheless! –  Daniel Rikowski Jun 5 '10 at 15:28
    
@DR: I suppose a VGA dummy plug or a product like this would be the same issue as connecting a monitor (heat and time). –  Dennis Williamson Jun 5 '10 at 16:21
    
This is a neat little app: mobaxterm.mobatek.net - no fiddling around with XMing and PuTTY or Cygwin which I could never get working satisfactorily (credit goes to Sam who was one of the SO devs who mentioned it in the comments: samsaffron.com/archive/2013/05/03/…) –  Kev May 21 '13 at 14:06
add comment

Another option is running GDM over VNC, which will give you a GDM login window over VNC. See Vnc & Gdm

share|improve this answer
add comment

Found it here, credits to Ata Roboubi.

Using the official nvidia driver, with "ConnectedMonitor" and "UseEDID"=False options as below, the driver will be forced to use the CRT-0 output without checking any EDID data.

Even if you let a configured mode string into the file, it will fall back to 1024x768.

/etc/X11/xorg.conf:

Section "Device"
        Identifier     "Configured Video Device"
        Driver         "nvidia"
        Option         "ConnectedMonitor" "CRT-0"
        Option         "UseEDID"     "FALSE"
EndSection

Resulting Xorg.0.log:

(**) Aug 12 19:35:46 NVIDIA(0): ConnectedMonitor string: "CRT-0"
(**) Aug 12 19:35:46 NVIDIA(0): Ignoring EDIDs
(II) Aug 12 19:35:47 NVIDIA(GPU-0): Not probing EDID on CRT-0.
(II) Aug 12 19:35:47 NVIDIA(0): NVIDIA GPU GeForce GTS 450 (GF116) at PCI:3:0:0 (GPU-0)
(--) Aug 12 19:35:47 NVIDIA(0): Memory: 1048576 kBytes
(--) Aug 12 19:35:47 NVIDIA(0): VideoBIOS: 70.26.26.00.01
(II) Aug 12 19:35:47 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Aug 12 19:35:47 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Aug 12 19:35:47 NVIDIA(0): Connected display device(s) on GeForce GTS 450 at PCI:3:0:0
(--) Aug 12 19:35:47 NVIDIA(0):     CRT-0
(--) Aug 12 19:35:47 NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
(II) Aug 12 19:35:47 NVIDIA(0): Display Device found referenced in MetaMode: CRT-0
(II) Aug 12 19:35:47 NVIDIA(0): Assigned Display Device: CRT-0
(WW) Aug 12 19:35:47 NVIDIA(0): No valid modes for "CRT-0:1280x1024"; removing.
(WW) Aug 12 19:35:47 NVIDIA(0):
(WW) Aug 12 19:35:47 NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) Aug 12 19:35:47 NVIDIA(0):     "nvidia-auto-select".
(WW) Aug 12 19:35:47 NVIDIA(0):
(II) Aug 12 19:35:47 NVIDIA(0): Validated modes:
(II) Aug 12 19:35:47 NVIDIA(0):     "nvidia-auto-select"
(II) Aug 12 19:35:47 NVIDIA(0): Virtual screen size determined to be 1024 x 768
(WW) Aug 12 19:35:47 NVIDIA(0): Unable to get display device CRT-0's EDID; cannot compute DPI
(WW) Aug 12 19:35:47 NVIDIA(0):     from CRT-0's EDID.
share|improve this answer
add comment

If you want a persistent session that's there even when you're not connected over SSH, you can use Xpra.

You can also use Xvnc, which will give you something similar, but probably a bit simpler, with the usual "virtual desktop".

You can also use Xvfb. This is a bit more versatile than Xvnc since you can decide yourself how to connect (Xvnc implies VNC usage).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.