Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

can you give me a way for enabling my remote desktop with cmd ? my remote desktop port is not listening on 3389 ! my server : windows 2003

share|improve this question

migrated from stackoverflow.com Jun 6 '10 at 20:44

This question came from our site for professional and enthusiast programmers.

2 Answers 2

To enable RDP via command line, just edit the registry with the reg command like this:

reg add "HKLM\System\CurrentControlSet\Control\Terminal Server" /v fDenyTSConnections /t REG_DWORD /d 0x00000000 /f

share|improve this answer
    
This will only work if the 'Terminal Services' service is started –  ggonsalv Jun 8 '10 at 3:06
    
True, but it is always started by default. If somebody disabled it, run reg add HKLM\System\CurrentControlSet\Services\TermService /v Start /t REG_DWORD /d 0x00000003 /f and then a net start termservice –  Jason Berg Jun 8 '10 at 3:27

If you mean remotely, which isn't clear from your question. If you don't, omit step 2 and 3

  1. Open Regedit on a Windows workstation
  2. Click File > Connect Network Registry
  3. Enter the name of the Server
  4. Navigate to HKLM\System\CurrentControlSet\Control\Terminal Server
  5. Change the value of fDenyTSConnections from 1 to 0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.