Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install a CRM on a Linux (Ubuntu 10.04) laptop to do some testing. Installing the current versions of Apache, MySQL and PHP, and getting the CRM to run is easy. It's when I try to go backwards and run it on a previous set of versions I run into problems. This is what I have done:

I have installed Apache 2.2.14, MySQL 5.0.83, and PHP 5.2.8. When I type something like mysql --version I get back what I would expect: version and distribution info. The same goes for Apache2 and PHP. The Apache server is running and so is mysqld.

So when I go to my browser and look at http://localhost/<CRM dir>/install.php Firefox offers to open the PHP file or save it, as if it doesn't recognize the file. What should happen is that I should get a welcome page and the installation wizard for this CRM distribution should start. I have tried so many different things I probably screwed up something along the way. I have restarted the servers over and over, and even recompiled the versions of MySQL and PHP with no problems. I am hoping I am overlooking something simple because I am lost. Any help is appreciated.

share|improve this question

Make sure your Apache has the proper PHP integration configured somehow.

LoadModule php5_module /some/path/to/modules/
AddHandler php5-script .php
AddType text/html .php
DirectoryIndex index.php
share|improve this answer
This is good, thanks. I will try it as soon as I can. Are these commands to run or lines in a configuration file? – nicorellius Jun 7 '10 at 13:56
lines in your config file (httpd.conf) – troyengel Jun 8 '10 at 8:55
Yes, I ended up figuring this out - thanks. The tricky part I have now is the LoadModule. I had to take that line out to run it. My php.ini file is not where it should be and I can't configure Apache2/PHP correctly. – nicorellius Jun 8 '10 at 15:06
up vote 1 down vote accepted

I rebuilt (recompiled) PHP and restarted the Apache2 server and it worked. I am having a different problem, but perhaps requires a new question.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.