Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am running Ubuntu Server on VirtualBox. I am not using X Windows, only the command line. It looks like it is redrawing the screen for every line that causes the screen to shift down. In other words if there is empty space on the screen below the current line, it works normally, but if the current line is at the bottom of the screen, when the system moves to the next line it refreshes the whole screen line by line. This causes the system to run very slowly because I have to wait for the whole screen to refresh for every line and it hits the CPU at 90%.

I installed Debian Lenny in VirtualBox and it didn't do this.

Why does Ubuntu Server redraw the screen for each line? Is there a way to make this behaviour go away?

Update:

I am running Ubuntu Server 10.04.

I found another solution to disable the framebuffer. I added blacklist vga16fb to /etc/modprobe.d/blacklist-framebuffer.conf.

ls -l /boot:

total 14268
-rw-r--r-- 1 root root  640617 2010-04-16 06:01 abi-2.6.32-21-generic
-rw-r--r-- 1 root root  115847 2010-04-16 06:01 config-2.6.32-21-generic
drwxr-xr-x 3 root root    4096 2010-06-07 17:38 grub
-rw-r--r-- 1 root root 7957975 2010-06-07 17:36 initrd.img-2.6.32-21-generic
-rw-r--r-- 1 root root  160280 2010-03-23 02:37 memtest86+.bin
-rw-r--r-- 1 root root 1687378 2010-04-16 06:01 System.map-2.6.32-21-generic
-rw-r--r-- 1 root root    1196 2010-04-16 06:03 vmcoreinfo-2.6.32-21-generic
-rw-r--r-- 1 root root 4029792 2010-04-16 06:01 vmlinuz-2.6.32-21-generic
share|improve this question
    
Do you have Guest Additions installed? What is your host OS? –  Dennis Williamson Jun 7 '10 at 11:37
    
Yes I have installed Guest Additons. My host OS is Mac OS 10.5.8 –  hekevintran Jun 7 '10 at 12:04

1 Answer 1

up vote 3 down vote accepted

Your framebuffer is enabled. Certain framebuffer configurations are not accelerated and will use the CPU to redraw the screen - in effect turning your CPU in to a bitblit engine when it decides to "scroll" the text. Disable it using the instructions found here, which will "tell" VirtualBox that you want "text" and not "graphics".

share|improve this answer
    
The instructions talk about editing things in the GRUB menu, but I don't have a menu to pick from when the VM starts. They also talk about a file (/boot/grub/menu.lst) that doesn't exist on my machine. I remember when I installed the OS it asked about using the whole disk or not. I chose whole disk. Does that affect whether I have a GRUB menu? –  hekevintran Jun 7 '10 at 23:10
    
GRUB is the default boot loader for Ubuntu (and on newer versions of Debian). If you can't see it, then it makes me wonder if you have something else installed, although I would be stunned if you were running LILO instead of GRUB. What version of Ubuntu are you running, and if you give the command ls -l /boot what are the results? Paste the answers to this into your question as a follow-up. –  Avery Payne Jun 8 '10 at 2:21
    
Updated. Is there a way to accelerate the framebuffer? Perhaps giving the VM more video memory? –  hekevintran Jun 8 '10 at 3:03
1  
@hekevintran: Maybe it's /etc/grub? Ubuntu has switched to grub2, which did away with menu.lst. –  grawity Jun 8 '10 at 9:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.