Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm completely new to working with SharePoint and Windows Server, but last week I was given a small brief to play with SharePoint 2010 to see how I got along with it.

Anyway I've set up a SharePoint server and had a mess around to get some new sites and pages created etc, but I'm now looking to have a try at importing some AD groups. As part of this I've look at these tutorials, here and here.

So far I've got through to the process of starting the User Profile Service which works fine, but when I get it starting the User Profile Synchronization service it sits on starting. But when I refresh the page or go to the monitoring section it shows it as aborted. Now I'm new to administering servers like I say and when I start the User Profile Synchronization service it tries to run as NT AUTHORITY\NETWORK SERVICE and asks for a password so I've been providing it with the admin password, now I'm not sure if this is part of the issue or not as I've checked the log files and they seem to say that it doesn't have permissions, which is fair enough, but I can't see how you can change the account even if I wanted to.

So if anyone could help it would be appreciated, if you need any further information to help with an answer, just let me know.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Just follow the instructions in this article and you'll be able to set it up successfully. http://www.harbar.net/articles/sp2010ups.aspx

share|improve this answer
    
Hello, thanks for the link, should have a chance to try it today then I'll let you know how I get on. –  manemawanna Jun 10 '10 at 7:49

Have you successfully setup the Managed Metadata service? Without it, the User Profile Synchronization Service will not start up and remain in a "starting" state.

share|improve this answer
    
Hi thanks for the response, yes when I previously tried I saw details of that and it was started. Just working through the guide Muhanad provided this morning. –  manemawanna Jun 10 '10 at 7:49
    
Are you sure, I have the UPS running and working fine without the Managed Metadata service configured.. –  tplive Jun 29 '11 at 21:46

I actually fell into TWO traps when I provisioned SQL for my SharePoint 2010 farm, and both traps were not very well documented either my Spence Harbar's famous UPS article (mentions it) or by Technet (no mention AFAIK). First of all I set up a named instance of SQL Server, like SERVERNAME\SHAREPOINT. Then I used the SQL server's FQDN (servername.domain.name\SHAREPOINT) name when I installed SharePoint, which is another thing the UPS can't handle.

I tried a lot of troubleshooting, but in the end was forced to reinstall SQL and SharePoint. Had a lot of trouble with uninstalling Office Web Apps and SharePoint and in the end I'm stuck with a trouble-ridden SharePoint install and only a few days until deadline. Oh well, it could be worse.. :)

Anyways, DON'T use SQL named instance OR SQL FQDN if you think you'll ever provision UPS, that's my point. Both work perfectly in all other scenarios, but you never know, do you.. :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.