Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The Apache2 server and PHP version seem to be in order, but when I launch the CRM installer at

http://localhost/<CRM dir>/install.php

The wizard says I need a minimum of PHP 5.1 and preferably PHP 5.2.x. The thing is, I am running PHP 5.2.8, and I know this from running

php --version

Plus, I spent a bunch of time learning how and (I thought, successfully) compiling PHP 5.2.8. It is quite likely I screwed up and don't have some libraries I need, but I'm not sure where to look first.

Thanks in advance.

PS - I know some of you will suggest going to the CRM's forums... I tried this; these are not good. I much prefer the expertise I get here on the Stack Exchange sites.

share|improve this question
    
what CRM are you using? –  Rwky Jun 7 '10 at 20:08
    
SugarCRM... Trying to install 5.2.0l Community Edition. –  nicorellius Jun 7 '10 at 20:18
add comment

1 Answer

up vote 3 down vote accepted

The command line may run 5.2.8, but may have nothing to do with the cgi or module that apache runs. What does a webrequest with <?php echo phpversion();?> tell you about the version? Possibly use a full phpinfo() to check what's provided & where. Especially if you compiled a version of php by hand changes are high you did it only for the CLI package.

share|improve this answer
    
I am still new to this server configuration - can you explain more what you mean? How would I do a webrequest for <?php echo phpversion();?>? And/or how would I do a full phpinfo()? I totally see what you mean, however, and I thought it might be something like this. Thanks! –  nicorellius Jun 7 '10 at 20:31
    
(1) create a file in your webdirectory (let's call it test.php). (2) Edit the file and enter <?php echo phpversion();?> (3) Open the url in your browser: yourdomain/test.php (e.g. localhost/test.php) and look at which version it reports. –  Wrikken Jun 7 '10 at 20:52
    
OK, that worked and, as you suggested, it reported that I am using PHP 5.3.2, which is what I DON'T want! Errgh... Thanks again. I have more work to do ;--) –  nicorellius Jun 7 '10 at 20:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.