Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have three Windows XP guests running on a recently upgraded 64-bit Ubuntu 10.04 system. Occasionally (on the order of once every few days), one of the guests will become non-responsive and the kvm process on the host which is running that guest will start consuming 100% CPU. It will continue to do so until it is killed. When restarted, it will be fine for a while, and then the issue repeats.

The kvm command line used to run all three guests is this:

/usr/bin/kvm -S -M pc-0.12 -enable-kvm -m 1024 -smp 1 -name bigdog21vmxp1 \
    -uuid ea47ff84-125b-16f7-9a4d-a6d0d8bab46a \
    -chardev socket,id=monitor,path=/var/lib/libvirt/qemu/bigdog21vmxp1.monitor,server,nowait \
    -monitor chardev:monitor \
    -localtime \
    -boot c \
    -drive file=/var/lib/libvirt/images/windowsxp-1.qcow2,if=ide,index=0,boot=on,format=qcow2 \
    -net nic,macaddr=54:52:00:02:06:0e,vlan=0,name=nic.0 \
    -net tap,fd=58,vlan=0,name=tap.0 \
    -chardev pty,id=serial0 \
    -serial chardev:serial0 \
    -parallel none \
    -usb \
    -usbdevice tablet \
    -vnc 127.0.0.1:1 \
    -k en-us \
    -vga cirrus \
    -soundhw es1370

Why do the systems misbehave this way sometimes? And what configuration can I change in order to fix it? Or, if the problem is due to a bug in kvm, what is the process for isolating a kvm failure so that the developers have a chance of fixing it?

share|improve this question
    
Have you tried using a different image type to see if the problem continues? I'd try a raw image file as it takes a lot of code out of play. Also is the image on local storage or being served via NFS? –  3dinfluence Nov 18 '10 at 5:14
    
Oh my. I forgot I'd posted this question. I also forget how I resolved the issue, but my Windows XP guests haven't been hanging for a while, so I guess I did somehow. –  Jean-Paul Calderone Nov 18 '10 at 5:33
    
Yeah I didn't realise how old the question was either. I wonder how it popped back onto the first page of questions. –  3dinfluence Nov 18 '10 at 19:57
add comment

2 Answers

What are the chances that the issue occurs whenever the Windows guest tries to restart (e.g. after an automatic update)? I always got freeze-on-restart behavior from Windows guests under libvirt+kvm on Ubuntu Jaunty; now that my host is running Debian Squeeze, it doesn't happen any more.

share|improve this answer
add comment

The best way I have to debug this is to remove all but the necessary arguments and add the removed arguments until it breaks again. That's the only way I could find my problem last time (on uec 10.10).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.