Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm running a mysql-server a long with apache and tomcat on a Gentoo box. To administer mysql I'm using phpMyAdmin. A couple of hours ago I received a call -- a user was unable to login to phpmyadmin. I logged on to phpmyadmin with the root user, and reset the password. The user was still not able to login. I then decided to give it a go myself, and even I wasn't able to login.

I tried creating several user accounts, none of them were able to access mysql via jdbc/mysql-client/phpmyadmin. The only user that seems to work is root.

What's even more strange is that websites that connect to mysql with a user other than root are still able to login and retrieve content from the database (it's mainly wordpress and a tomcat webapp). I have made sure it's not just cached, I was able to post SQL queries to the database via these web apps still. However, I am unable to login to phpmyadmin/mysql-client with this user and I am also unable to set up a connection with this user for any new web-applications.

Any help is immensely appreciated.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Have you tried a FLUSH PRIVILEGES; after your GRANT's ? If so, is it not simply a host question (which syntax did you use to create the users)?

Further, I seem to recall that in some error-recovery modes only root was able to login, after which a restart of mysql was required, but it would take an explicit recovery mode start, and wouldn't allow your other websiteusers to log in.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.