Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using a Media Temple DV server with CentOS upon trying to install ImageMagick via yum, I get the following error:

There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   /usr/lib/python2.4/site-packages/rpm/_rpmmodule.so: undefined symbol: rpmdbCheckTerminate

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.3 (#1, May 24 2008, 13:47:28) 
[GCC 4.1.2 20070626 (Red Hat 4.1.2-14)]

Can anyone shed some light on what I might be able to do to fix this?

Thanks!

share|improve this question
    
What does rpm -V -f /usr/lib/python2.4/site-packages/rpm/_rpmmodule.so say? It would be good if you could also run rpm -V python yum. –  Cristian Ciupitu Jun 9 '10 at 1:34

2 Answers 2

up vote 2 down vote accepted

Your rpm and rpm-python versions have gotten out of sync. This can happen if you've built your own rpm but not the Python bindings, or vice versa. Run rpm -q rpm rpm-python and compare the returned versions, and then rpm -V rpm rpm-python to verify the integrity of the packages' files.

share|improve this answer
    
The first shows: rpm-4.4.2-48.el5 rpm-python-4.4.2.3-18.el5 and the second: .M.....T c /etc/cron.daily/rpm Unsatisfied dependencies for rpm-python-4.4.2.3-18.el5.i386: popt = 1.10.2.3-18.el5, rpm = 4.4.2.3-18.el5, rpm-libs = 4.4.2.3-18.el5 –  mike Jun 10 '10 at 0:54
1  
And there you have it. Your system is half-updated from an older version. Download and run rpm -Uvh against all of these at once: mirror.centos.org/centos/5/os/i386/CentOS/… mirror.centos.org/centos/5/os/i386/CentOS/… mirror.centos.org/centos/5/os/i386/CentOS/… –  Ignacio Vazquez-Abrams Jun 10 '10 at 2:01
    
when trying to install those packages, I get: rpm = 4.4.2-48.el5 is needed by (installed) rpm-build-4.4.2-48.el5.i386 rpm = 4.4.2-48.el5 is needed by (installed) rpm-devel-4.4.2-48.el5.i386 - So i try installing them and I get another list of dependencies. Can I just downgrade something? –  mike Jun 11 '10 at 0:06
    
If you can force those three packages in then you can use yum to update all the others. Since forcing a package is a bad thing to do in the general case, you'll need to refer to the man page on how to do it. –  Ignacio Vazquez-Abrams Jun 11 '10 at 0:18
    
Thank you very much! That second comment (upgrading packages) did it for me and saved a bunch of time searching. –  Benjamin Manns Jul 1 '10 at 13:39

I had the same problem, and just to add to the fracas, if you are on Media Temple, make sure developer Tools and Root are turned on ;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.