Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My customer have an office small office with just a wifi router. He use this router for internet connectivity and file transfer operations between the desktops.

Recently the file transfer activity between desktop (all osx based) is increased a lot so he bought a switch (no connected to the router, too far away) for transfer the file over the cable instead over the wifi.

Problem: How to bind the file sharing service just to the Ethernet interface and exclude the wifi interface ? (actually the service binds to the wifi automatically and there are no options about the interface binding)

share|improve this question

2 Answers 2

I don't know the answer to your question, but my experience has always been if I had wireless & ethernet connected, the data will travel over the fastest interface. The only exception is if I connected to the server while only connected with wireless, then connected to ethernet after. In that case, the data would still travel over wireless. A question though... why do you need both on?

share|improve this answer
    
Wifi -> Router -> Internet | Lan -> just for file sharing. If i deactivate wifi, the service switch automatically to the Ethernet but if I activate the wifi again it switch again to the wifi :( –  Cesar Jun 9 '10 at 4:15

Based on your description of the network, it seems like your AFP server has two active network interfaces: One is wifi, and the other is Ethernet. Each of these interfaces should have a different IP address. If that's the case, you can have your clients connect to the IP address of the server's Ethernet interface.

Of course, it would be much nicer if you had DNS names attached to these interfaces so your users don't have to type IPs, but that seems to be beyond the scope of what your network is set up with.

Alternatively, you can experiment with re-ordering the network interfaces in System Preferences (on both the clients and servers). That is the order in which the computer will attempt to route to a remote host (that is, the top-most one will be your default route). It will not choose the fastest route automatically as churnd suggests.

share|improve this answer
    
Well, actually the problem is that the daemon binds only on the wrong interface :( –  Cesar Jun 23 '10 at 23:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.