Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I assume it has something to do with permissions. How would I set the folder to the appropriate permissions on windows? It worked fine when I left it at the default subdirectory of htdocs.

Thanks!

share|improve this question

1 Answer 1

It may be a problem with Windows permissions which you have probably already checked. Another thing to consider is the Directory permissions in httpd.conf as that is where Apache checks to see what it is allowed to do with the files. I made that mistake my first time changing the DirectoryRoot also.

Here is an example. If the old directory was /srv/http, then you might have something like:

<Directory "/srv/http">
  Options Index FollowSymlinks
  AllowOverride none
  Order allow,deny
  Allow from all
<Directory>

Simply change the "/srv/http" part to you new directory, or make a new entry which includes your new DocumentRoot The important bit is the "Allow from all" since you should have a <Directory /> entry that includes "Deny from all" to disallow access to the rest of your system.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.