Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running Fedora 12 and I've setup a partition separate from my root partition to keep shared files and home directories.

Now, I've been having permission issues where it says the user cannot chdir into their home directory (/files/home/*). Now, I fixed this originally by chmodding / to 0755 and the home directories also to 0755. And yes, the user is the owner:group of their home directory.

Now get this, I didn't change a thing, rebooted, everything still works. Great, right? I boot the server up a day later, and now same ol issue. This is a home server that wasn't on at all at any point in between the working state and non-working state. Also, nothing else was modified.

Any ideas?

Thanks!

== edit ==

Ok. So I've narrowed it down to an SELinux issue. If I run "setenforce 0" everything is fine. However, I'd prefere to keep SELinux enabled. Is there anyway around this?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

It seems that this is a "non-standard" location for home directories. You can change the policy of that box to label these directories correctly, then everything should work like expected.

Assuming that I understood your problem correctly, the commands to change the policy would be

 semanage fcontext -a -t home_root_t "/files/home"

This should tell the system that this is a root dir for home directories. With

 restorecon -r /file/home

should do the relabeling then. The directories in /files/home should have the user_home_dir_t context, the normal files in the home dir user_home_t.

HTH. Look at the SELinux Docs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.