Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
(1)  mount    -t nfs remotehost:/remotedir localmountpoint -o owner,rw
(2)  mount -v -t nfs remotehost:/remotedir localmountpoint -o owner,rw

(1) Used to work with Ubuntu 9 and now fails with Ubuntu 10 (2.6.32-21-generic kernel) with the error:

mount.nfs: an incorrect mount option was specified

Strangely, adding -v (verbose) in (2) makes the problem go away.

This is currently a blocker for me because the fstab line:

remotehost:/remotedir localmountpoint nfs owner,rw   0 0

causes the same error (I don't believe I can specify verbose in fstab).

Is this a bug in mount or are my options really incorrect?

share|improve this question
add comment

2 Answers

Specifying proto=udp seems to fix this:

(command line) mount -t nfs remotehost:/remotedir localmountpoint -o owner,rw,proto=udp    
(fstab)        remotehost:/remotedir localmountpoint nfs owner,rw,proto=udp   0 0
share|improve this answer
add comment

Are NFS versions between boxes the same? I would think Ubuntu 10 would have changed the default to nfsv4. Maybe try specifying nfs3 in the fstab entry, assuming your other node is using nfs3.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.