Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Have NLB set up and working. Just two servers, web1 and web2. I set up NLB on web1 and can view both machines as Converged. (I had to specify a login/pass to connect to web2). On web2, looking at the NLB Manager, it only shows web2 and says in the log "Accessed Denied. Error connecting to web1".

Any ideas how to fix?

share|improve this question

3 Answers 3

Often the NLB manager doesn't refresh it's view so the access denied error message may be stale. Try restarting it.

Another thing to check is the cluster type (unicast or multicast) and which adaptor you are connecting to as part of the cluster. If you have picked the cluster address on one side and not the other it may appear to be working, it just depends on whether the request was redirected to the correct machine at the time the request was made.

share|improve this answer

I have faced this issue multiple times and what i have seen as a simple solution is - the DNS resolution fails in most cases and thus the error. a work around can be - include the IP address, alias and the hostname of the machine you are adding in your cluster.

HOST file is ideally in the following location of your windows 2008 server - C:\Windows\System32\drivers\etc\"

-Djay.

share|improve this answer

MAke sure you use the same password on both for setting up NLB.

share|improve this answer
    
Isn't it bad practice to have the same password for two administrator accounts on different machines? –  Igor K Jun 10 '10 at 8:38
    
No when settiung up NLB you pick a password. I have not done it for a while so.... –  ggonsalv Jun 10 '10 at 10:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.