Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running tracd on a Synology DS209+II NAS. For that purpose, I have created a script in /opt/etc/init.d called S81trac:

myserver> ls -l /opt/etc/init.d
-rwxr-xr-x    1 root     root          127 May 19 09:56 S80apache
-rwxr-xr-x    1 root     root          122 Jun 10 10:17 S81trac

This file has following contents:

# run tracd
/opt/bin/tracd -p 8888 -auth=*,/volume1/svn/svn-auth-file,mydomain -e /volume1/trac-env

And this actually works, except, the NAS never really finishes booting: The blue light keeps flashing. Also, reboot doesn't work anymore (it hangs) and I have to use killall init to reboot the machine.

I have tried running tracd in the background, by appending & to the last line of S81trac. After rebooting, the blue light stops flashing. But ps | grep tracd is empty and I can't connect to the trac instance from my PC.

I guess I'm doing something wrong here, but what?

share|improve this question
up vote 1 down vote accepted

Rather than using & to background it, use --daemonize (or the shorter form -d). I think that should address your problem. (You may want to consider using --pidfile=... as well. tracd --help would also be worth perusing.)

Disclosure: I am one of the Trac Devs.

share|improve this answer
Excellent! This worked like a charm. Thanks! – Daren Thomas Jun 10 '10 at 13:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.