Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to compile rsync-3.0.7 on Solaris 5.10 on an Intel chipset.

When running ./configure I see the following (obviously erroneous lines):

checking size of int... 0
checking size of long... 0
checking size of long long... 0
checking size of short... 0
checking size of int16_t... 0
checking size of uint16_t... 0

In config.log I see the following lines:

configure.sh:5448: /tool/sunstudio12.1/bin/cc -xc99=all -o conftest -g -DHAVE_CONFIG_H   conftest.c  >&5
"conftest.c", line 123: warning: statement not reached
cc: Fatal error in cc : Segmentation Fault
configure.sh:5448: $? = 1
configure.sh: program exited with status 1

Segmentation fault? What could be causing a simple test script to segfault during compilation?

share|improve this question

3 Answers 3

up vote 1 down vote accepted

This wont fix your compiling issues, but you could always look at using the opencsw repo http://opencsw.org/ they have this version of rsync already compiled and have a useful app called pkg-get for performing the installations

share|improve this answer
    
Good answer. To be honest I'm just recording what problems I've had and how I solved them on here because not only do I think I'll come across this again but I'm sure other people will too. –  PP. Jun 11 '10 at 8:37

I ran into the same problem, but couldn't use the -xc99=all,no_lib workaround (the program I was building needed all c99 features) and tried manually running the cc command under truss. It showed the segfault happened just after trying to open /lib/values-xpg6.o. This file wasn't present, but is available in the SUNWarc package. I installed that and the segfault went away.

I'm not entirely sure what the root cause was, but that should help anyone for whom the above workaround fails.

share|improve this answer

The option -xc99=all was causing the segfault. A description of the option can be found here which states that the default is -xc99=all,no_lib (which doesn't cause the compiler to segfault).

To make the configure script work I edited configure.sh it and replaced the instance of -xc99=all to -xc99=all,no_lib

Answered my own question so that others that encounter this issue may have a vector to try in establishing a work-around.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.