Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So i moved to a new server and i want to install gnome desktop environment to access my server via vnc viewer.

But, i don't remember how i managed to install last time, so i tried

yum groupinstall "GNOME Desktop Environment" command and server said

Warning: Group GNOME Desktop Environment does not exist. No packages in any requested group available to install or update

It's a brand new server so i didn't add any repos or else yet

It's a centos 5.5 server ...

share|improve this question

6 Answers 6

The list of available groups can be shown with yum grouplist. If it doesn't show up then someone (is this a VPS?) may have disabled or crippled the default yum repos.

If you can't get the group installed regardless then you can still get VNC access by installing vnc-server and configuring that.

The next option down would be installing an X server on your local system and doing X forwarding via SSH.

The next option would be to install freenx and use NX to access the system.

The final option, and the most popular by far, is to just learn how to administer the system via command line.

share|improve this answer
    
its a dedicated but minimal install (its a web server), i checked yum grouplist and output is : Installed Groups: Yum Utilities Available Groups: Beagle FreeNX and NX Horde Mono Tomboy XFCE-4.4 So i just need to know how can i add more grouplist to yum, should i add a repo or what ? –  Barbaros Jun 11 '10 at 1:09

Hello Ignacio, you can launch command:

yum groupinstall "Desktop"
yum install xorg-x11-fonts-Type1

It should work. The second command is to install a font package that seems to be missing into the group configuration. Without this package your Gnome will be full of squares :)

Andrea

share|improve this answer

Please try this one, in my case it worked OK:

yum groupinstall "Desktop" "Desktop Platform" "General Purpose Desktop"

share|improve this answer
    
Worked :) thank you. –  erm3nda Sep 24 at 2:39

Looking on one of my machines, you have the right group name. Somehow the minimal install must leave you with an incomplete repository. Try to enable the repository for the CD/DVD and install from that.

If that doesn't help, worst case you can pull the list of packages from comps.xml on the DVD and install them yourself.

@Ignacio - Even if there is no X :0 console, vnc-server still needs gnome binaries installed, or at least some GUI like xterm + twm.

Oh - and I've heard there can be missing/broken dependency rules when upgrading from a minimal system to a fuller one, so keep that in mind if you see package conflicts, etc.

share|improve this answer

I had the same error. try with

yum install xorg-x11-fonts-Type1
yum groupinstall "X Window System" "Desktop"
share|improve this answer

The following worked for me

yum groupinstall 'GNOME Desktop Environment'
share|improve this answer
    
This doesn't really answer the question. This is exactly what the user said didn't work. –  Scott Pack Oct 14 '12 at 0:50
    
Yep. On my case i got Warning: Group GNOME Desktop Environment does not exist. and cannot install it. –  erm3nda Sep 24 at 2:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.