Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am currently running a linux bridge in the following configuration

alt text

ADSL Modem: 192.168.1.1

Linux Bridge:

eth0: 192.168.1.2

eth1: no address

Wireless Router: 192.168.0.1

My issue is that i cannot access the "Linux Bridge" shares using the WINS name of the server via client systems (yes i understand it is a transparent bridge but i can access it via the 192.168.1.2 address this is not on the same subnet as the client systems).

This is the global section of my SMB.CONF

[global]
        unix extensions = off
        os level = 20
        netbios name = server
        guest account = nobody
        server string = 447 Server
        security = share
        #unix extensions = no
        #wins support = yes
        #wins server = 192.168.0.1
        name resolve order = wins lmhosts hosts bcast
        interfaces bridge1 eth0 eth1 lo
        bind interfaces only = yes

Can i access a bridged server using it's WINS name to access samba shares?

Cheers

Chris

share|improve this question
2  
My head asplode. What are you trying to do? There's no such thing as a "WINS name", either. You have a freakish mix of different subnets here, by the look of it (you don't mention a subnet mask-- maybe you're doing all of this in a /16). Really-- what ARE you trying to do? –  Evan Anderson Jun 12 '10 at 3:55
    
I have a transparant linux bridge monitoring traffic between two routers and i would like clients two be able to access it via (WINS Microsoft's implementation of NetBIOS Name Service) it's NETBIOS Name. Currently clients can access it via it's address 192.168.1.2 but not it's netbios name. There are only two subnets and certainly no "freakish mix". TO put it to you simply "I am trying to access shares on a transparent bridge using a NetBIOS name". –  Christopher Wilson Jun 12 '10 at 18:16
add comment

2 Answers

up vote 1 down vote accepted

Personally I suspect the majority of your issues are related to your wireless router.

Setup your wireless router like described here so it will act as a bridge instead of a router. Your network will be far simpler and will most likely work correctly. You will not need WINS or DNS. Broadcast-based name resolution should work.

You don't mention how your clients connected to the wireless router get their IP address. Are they set statically or do you have DHCP setup. If you have DHCP setup are you sending options 44 with a list of WINS servers and 46 with the node type? If your clients are not setup to use the WINS server then they will not use it.

As an another alternatively why not setup a DNS server on your Linux box and push that to your clients. Setup a zone for your local network and deliver a search domain to the clients that corresponds to the domain you have setup.

share|improve this answer
add comment

Do the clients see the server in their network neighbourhood? If not, the wireless router is not forwarding broadcast packets.

In that case, you should configure all the clients to use 192.168.1.2 as the WINS server, and then you should be able to use the server directly from windows clients. For GNU/Linux clients you also need to add wins to the hosts: line in /etc/nsswitch.conf (preferably just before a NOT FOUND entry).

share|improve this answer
    
They do not see the box in network neighborhood. So what your saying is the linux box should act as a WINS server and clients pointed in the right direction, easy will give this a go. Cheers –  Christopher Wilson Jun 12 '10 at 18:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.