Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is a recent problem... MySQL was working and a couple of days ago I must have done something. I deleted MySQL and tried reinstalling using the .dmg file. The mysql.sock file never gets created and I get the following error messages:

Hristo$ mysql
Enter password: 
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/mysql/mysql.sock' (2)

I also tried stopping Apache and installing but Apache gave me an error... I don't know if this is good or bad:

Hristo$ sudo apachectl stop
launchctl: Error unloading: org.apache.httpd

I tried the MacPorts installation as well but the socket file still didn't get created. I don't really know what to do and I don't want to reinstall Snow Leopard and start from scratch :/

I also tried installing the 32-bit version and same deal. No luck.

Finally... I tried doing the source installation but when I get to the configuration step, I get the following error:

-bash: ./configure: No such file or directory

The file is "mysql-5.1.47-osx10.6-x86_64.tar.gz" so I think it is the proper file for source installation and yes I have a 64 bit system. I don't know what to do anymore.

Any ideas?

Thanks, Hristo

share|improve this question
add comment

2 Answers

I would recommend you to go thru the error_log files and see if there is anything there to help you with what is going on...

About the mysql, verify if the data folder exist, has the right user and permissions before starting it, there is also scripts/mysql_install_db.

Usually when the data folder has no permission, dont exist or something alike, mysql won't create the sock and in most cases won't start.

This may also help you: http://hivelogic.com/articles/installing-mysql-on-mac-os-x

I am not much a MAC user ...

PS: don't know if this Question was moved from stackoverflow or created again anyway here it is.

share|improve this answer
add comment
up vote 0 down vote accepted

Finally figured it out... I tried pretty much everything but it all came down to deleting every instance of MySQL and I was missing something when I was deleting everything. To completely uninstall MySQL:

sudo rm /usr/local/mysql
sudo rm -rf /usr/local/mysql*
sudo rm -rf /Library/StartupItems/MySQLCOM
sudo rm -rf /Library/PreferencePanes/My*
sudo rm -rf /Library/Receipts/mysql*
sudo rm -rf /Library/Receipts/MySQL*
sudo rm /etc/my.cnf

Also, you have to remove the line “MYSQLCOM=-YES-” from the /etc/hostconfig file. My problem was that I never removed the /etc/my.cnf file!!! If you don't delete this file, apparently you get socket issues! So that was the culprit. Then I just did a regular install from the .dmg file from the MySQL website and everything works :) WHOOO!

Thanks for your suggestions and time!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.