Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a dedicated server running on a Dell PowerEdge 850 with CentOS 4.4 and HSphere 3.0 Patch 6 colocated at a datacenter.

Last night my hosting company had to schedule a change in the power bar, and I gave the go ahead for them to shut down the server and bring it up when they are done. Since they do not have admin access to the machine, I suppose they did a forced shutdown.

When the machine was brought up, I found that all my domains (and sub-domains) are now pointing to an "Apache 2 Test Page" instead of the pre-configured sites that were running prior to the shutdown. This apparently only affects the standard sites running on port 80 - my Webmin instance running at port 1000 is still accessible for example, as well as my HSphere control panel running at port 8080.

I've checked the config settings using the HSphere UI for each of the sites, and didn't find anything wrong. I've also tried rebooting the server via SSH, which does not rectify the problem. I've previously done reboots with no issues; the sites would just come right back up when its done, but not this time. I'm guessing some configuration file got corrupted or overwritten this time?

Anyone with experience with HSphere and can provide some advice on what's happened and how to solve it? Thanks. (I do not have an active support agreeement for HSphere since Parallels took over and increased the min. license to 200. I only had 25 license for use by family and friends.)

Thanks in advance.

share|improve this question

2 Answers 2

We run several hundred hsphere boxes and I'm at a bit of a loss as to the problem from you description.

My only suggestion would be to check the correct httpd is running (did you install and start a new httpd rather than the hsphere supplied httpd?).

Also check the sites.conf and other httpd.confs are being loaded.

Cheers, Carl

share|improve this answer
    
Hi Carl, thanks for answering. I'm at a loss too from what little info I can glean from the situation. Nope, no changes has been done (no new installs of httpd or anything) to the server, and all the sites were working prior to the forced shutdown conducted by the datacenter. After the server was switched back on after replacing the power strip, all the sites being served via port 80 now points to an Apache Test page, however any other apps served via other ports (8080 for Hsphere, 1000 for webmin) continues to work. I'm guessing some apache config file got corrupted but can't locate it. –  Darkwoof Jun 14 '10 at 3:45

I still can't locate where the problem went wrong, but I decided to experiment with running the HSphere updater to see if it can restore the configuration files.

It worked. =)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.