Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using Debian Linux 5.0 with Webmin and Virtualmin. Everything works fine except the BIND DNS Server. It says

Failed to start BIND : Unknown error.

Any ideas? I've googled about this problem and found some answers, but didn't help me. I still couldn't start it.

Thanks in advance for any help! Gabe

share|improve this question
add comment

2 Answers

Increase the logging level, put this on named.conf:

 logging {severity debug;};

More info about logging directive:

http://www.zytrax.com/books/dns/ch7/logging.html

share|improve this answer
    
Thanks for the reply. Should I check the logs after I put this code in named.conf? –  Gabriel Jun 14 '10 at 4:56
    
After you added the line to your named.conf and restarted named. –  joschi Jun 14 '10 at 5:29
    
Gabriel: yes, of course. –  lrosa Jun 14 '10 at 15:25
add comment

This error is not coming from BIND, but from the startup script or wrapper.

Try running BIND manually, from a root prompt, with:

named -g -c /dev/null

If this starts, it means BIND is installed and working properly. The next step is to find out what configuration file it may be using. You can try leaving off the -c /dev/null part and seeing what happens. If it starts, there is a config file somewhere that it found and loaded.

If no file is found, use the -c option and point it at your named.conf file specifically.

If those steps all work, then I would check the path that your wrapper script tries to run to ensure that it has the correct one for named.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.