Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have the BT broadband forwarding on to an internal machine with an IIS web server running. Thats fine, it goes to the sharepoint app, so the outside world can see this app.

Thing is we need another app running (a MVC ASP.Net app) and I have set it to :8080.

Internally I can get to it fine, but not when I type the IP number.

eg. 80.100.232.129:8080

is this something I need to set on the broadband router or something with SBS or somewhere else?

thanks in advance

share|improve this question

2 Answers 2

You just need to setup your external 8080 to forward to your internal IP on 8080 as well, basically the same as you've done already.

share|improve this answer
    
@chopper3 @boymars thanks; yes got there but seems not to be working as yet. rule is set but still blocking! –  bergin Jun 14 '10 at 10:56
1  
I don't have a BT HH to hand (I actually work for BT but not on that product line!), perhaps 8080 is the remote management port - have a look in the management options. –  Chopper3 Jun 14 '10 at 11:25
    
ahh ok whats a good port number to choose? –  bergin Jun 14 '10 at 11:29
    
currently looking at: en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers –  bergin Jun 14 '10 at 11:30
    
hmm, ok well its working on the intranet fine, so the port works and the firw=ewall setings on the box are ok - 8080 is on both port and host port, dunno if that makes a difference (ie on the from: and to: ) –  bergin Jun 14 '10 at 11:42

it sounds like you're already port forwarding traffic to IIS on port 80. you simply need to add a rule to forward 8080 to the internal server in your router's NAT/port-forwarding options.

this will make it available to the outside world.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.