Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an ancient fax device with a printer interface that only accepts postscript level 1 documents formatted in a specific way. I only have access to this printer over the lpd:// protocol.

I have some old documents from our previous system that work fine on our Unix machines, but they are altered somehow by CUPS when I use lp on our Linux system. The PDF files that end up in the print queue are significantly modified versions of the original, and although they still render in ghostscript, they don't do anything on the printer.

I'm wondering if there's a way to tell CUPS "don't process this, just send it to the printer without modification", or whether there's a lpd client or procedure I could try?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You can tell it to send RAW using the following command:

lp -d printer_name -o raw filename

-o lets you specify an option. In this case, it specifies no PPD to be used.

share|improve this answer
    
Thanks so much, that's exactly what I'm after. –  Ash Jul 9 '10 at 0:23

In the printer administration tool on my system (Fedora 12) I was able to add a "Generic" "PostScript Level 1 Printer". You may be able to do the same there.

share|improve this answer
    
I should have mentioned that I am using that generic driver. For some reason it reformats the postscript document between lp and the remote print spool (I am assuming this is CUPS' doing). –  Ash Jun 16 '10 at 2:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.