Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I used to mount a windows share in Ubuntu server, with an entry in fstab:

//data/SharedFolder /media/SharedFolder/ smbfs user,defaults,credentials=/root/.creds,uid=root,gid=root 0 0

/root/.creds is a text file with three lines, my username, password and domain.

Users on the ubuntu server could write to this mount, but then I upgraded to 10.04 and now only root can write. Regular users can still read though.

mount currently tells me:

//data/SharedFolder on /media/SharedFolder type cifs (rw,mand,noexec,nosuid,nodev)

How do I make it world writeable again?

Thanks

share|improve this question
    
I've tried adding a umask parameter (umask=0000), but don't seem to affect the permssions. I also changed the gid from 'root' to a group that all users are in, but as the group still doens't have write permission, this didn't help... –  aidan Jun 15 '10 at 15:57

1 Answer 1

up vote 3 down vote accepted

First of all, you'll want to change your filesystem type from smbfs to cifs in your /etc/fstab entry. That'll change how things behave just because of that.

Also, you might want to look into using the 'noperm' mount-flag. This tells the server to not do ACL checks, and rely on the server hosting the mounted share to provide that. If you really want everyone to get access to that share, this could represent a large bat to accomplish this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.