Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

(I've asked this over on stackoverflow already, but thought I'd ask here as well)

I'm currently running an ASP.NET application on IIS 7.5 on Windows 7. When I access this application on Internet Explorer (either 6, 7 or 8) it is incredible slow and often fails to load at all. There are messages at the bottom saying:

Waiting for http://localhost/....... or sometimes waiting for about:blank (I've read that this can be a virus, but I've run all the usual checks and it's not).

constantly, but it returns with the usual: "Internet Explorer cannot display the webpage"

I've also tried this by using 127.0.0.1 and the machine name, with the same results.

I've tried the same application on the latest Firefox, Safari, Chrome and Opera and they all work fine. I've also installed the same application on a Windows Server 2003 machine, and it all works fine via Internet Explorer.

I've also turned off the IPv6 setting on the LAN connection.

Soes anyone have any ideas why this doesn't work with Internet Explorer and yet does with other browsers?

share|improve this question
add comment

closed as off topic by John Gardeniers, Magellan, MDMarra, HopelessN00b, mdpc Nov 12 '12 at 17:41

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

This may be unrelated, but I had intermittent problems with almost all connections to localhost / loopback interfaces under Windows 7. The issue affected not only IIS 7.5 but also local proxy services, port forwarding by ssh etc. It turned out that the cause was that I had accidentally left the "Receive Window Auto-Tuning Level" setting at "experimental" after some network testing.

The current value can be displayed with the following command:

netsh interface tcp show global

To reset it to normal, issue the following command as administrator:

netsh int tcp set global autotuninglevel=normal

This solved my problem.

share|improve this answer
add comment

My guess is that you have the auto-detect settings in the connections, or maybe an incorrect proxy setting. I would make sure you unselect all the options in the "Tools->Internet Options->Connections" and try that. Also, try using the IP Address 127.0.0.1 and see if that does not reproduce the problem.

Finally, to rule out if its something on the server-side (IIS, which I'm pretty sure its not) you can enable Failed Request Tracing and make sure there is nothing taking too much time. http://learn.iis.net/page.aspx/266/troubleshooting-failed-requests-using-tracing-in-iis7/

share|improve this answer
    
Thanks for your reply. Auto-detect is off and there is no proxy configured. I've also tried 127.0.0.1 and the machine name and the results are the same, on IE only. All other browsers don't have this issue - which is the weird thing and also why I'm reluctant to think it's IIS as otherwise it would be across all browsers. That said, I'll give the tracing a go, sure why not? Thanks for the link. –  Ian Devlin Jun 21 '10 at 9:10
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.