Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to connect to a user session who's using remote desktop on my windows server 2003 × 2024, from task manager users but it comes up with Connect Password Required. I tried his password that he uses to log on to RD but it wont work, i tried every password i know of and nothing. How do I connect to his session? What password do i use and if that's the one why wont it work? Thanks.

share|improve this question

2 Answers 2

I have to admit that I've never tried doing what you're doing, but I'm wondering: even though you're connecting to his session (as opposed to shadowing his session) do you still need the ability (user right) to shadow his session in order for this to work?

share|improve this answer
    
i have found the solution i can use from task manager then users the chose which user i want to connect ->right click remote control now i can troubleshoot in the TS server . if i clicked on connect from the task manager it will request for password of the user that i am trying to connect to his session witch i don't know . and it will log him out which is use less for . thanks for reading and thanks for trying to help me . Hitham Melhem –  hitham Jun 16 '10 at 8:12
    
Well I'm confused. In your original question you stated that you tried the user's password. Then in your comment to my answer you said you didn't know the user's password. So did you get it working or not? –  joeqwerty Jun 16 '10 at 23:16

For doing a 'Connect' to his session, you're literally taking over control of that session and punting the user out of it. In this scenario, you need to provide the user's own credentials, possibly including the logon domain like DOMAIN\username.

If on the other hand you want to connect alongside the user to help them out, you should be going via the 'remote control' option, rather than 'connect'.

To do this you will need to be a local administrator of the server, and possibly configure GPO here: Computer Configuration -> Administrative Templates -> Windows Components/Terminal Services -> Sets rules for remote control of terminal services user sessions = "Full Control without user's permission"

share|improve this answer
    
In the OP's scenario there's no username component in the security prompt, only a password field. I'm assuming (maybe incorrectly) that since the OP is initiating the connection as a user other than the logged in user who's session he's trying to connect to, the he needs to have permissions to remote control (shadow) the session, even though he's connecting to it rather than remotely controlling it. –  joeqwerty Jun 16 '10 at 0:01
    
If you do a 'connect' to another users session you get a prompt that says 'Connect Password Required':'Enter the selected User's password.', with no username option. This is what I think the OP's seeing. I had to go check myself though, rarely use this method. –  Chris Thorpe Jun 16 '10 at 0:11
    
Which is what I was saying, but maybe not so clearly. –  joeqwerty Jun 16 '10 at 0:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.