Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using MySQL server on Ubuntu 10.04 and after changing the bind-address from to my webserver IP in /etc/mysql/my.cnf the mysql server fails to load. Any clues will be highly appreciated!

I have tried disabling iptables but useless


share|improve this question

migrated from Jun 16 '10 at 5:08

This question came from our site for professional and enthusiast programmers.

Have you tried to take a look at the mysql server log? – Itay Moav -Malimovka Jun 16 '10 at 4:06
Post your my.cnf plz – user47581 Jun 16 '10 at 5:08

We too had the same problem exactly on Lucid Lynx, while not having it on earlier Ubuntu releases. You know you're hitting the same issue if:

  1. mysql error log says it can't bind to that address or the address doesn't exist or something like that (can't remember the exact wording)
  2. mysql works perfectly if you start/restart it after booting the system

Seems like Ubuntu 10.04 tries to start MySQL before having assigned ip addresses to all network interfaces, so you don't actually have your ip setup when it starts.

We workarounded it by binding mysql to the 'any' address ( and opening an hole for its port in our iptables (which is default closed for any traffic on any port on any ip).

share|improve this answer

bind-address is the address which MySQL server listens, it should be for local connection and machine IP for remote connection. Why you change the bind-address to web server IP? Is the web server in the same machine of MySQL server?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.