Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Alright, so I need the soap extension enabled in php. When I run phpinfo(), it's not there, so I'm guessing I have to recompile?

I can follow tutorials online to recompile the most recent php version for centos, but will it generally just work after that? Or does apache need to know to use the new installation?

Thanks for any direction you can give me.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Probably: yum install php-soap would do the trick. Whenever the PHP manual says 'you have to recompile' your first instinct should be 'there must be a package for my distribution'.

Unless you already did compile PHP by hand, in which case it might be necessary to take the more difficult route.

share|improve this answer
    
Compiling PHP by hand is actually rather simple but more complicated then a package obviously. –  Antoine Benkemoun Jun 16 '10 at 23:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.