Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've setup a Windows 2008 Server in a Cloud Environment.

I am able to RDP to this Windows Server ("aka CloudServer") in the Cloud Environment.

When I establish PPTP VPN connection from the CloudServer back to our Windows Server ("aka OfficeServer"), my RDP session is dropped and it won't let me RDP back in.

The only way how I can RDP to the CloudServer is using the DHCP ip address issued from the OfficeServer.

What do I need to change on the CloudServer?

Thanks in advance for your help!

  • Jennifer
share|improve this question
add comment

1 Answer

Without seeing the IP addresses assigned to the machines in play here I can only stab a guess. It sounds, to me, like you've got the default "Use default gateway on remote network" box checked in the properties for your PPTP connection, and after you initiate the PPTP connection traffic is no longer flowing in such a way as to allow the RDP connection to work the way it did prior.

Think through what happens to the routing table when you initiate the PPTP connection (and turn off "Use default gateway on remote network" if you want to see what effect it has) and how that differs from what the routing table looks like when there is no PPTP connection running. I suspect some thought about how the traffic flows will set it straight in your mind.

share|improve this answer
    
Hi Evan. I'm using a Dial-On-Demand VPN Connection from Routing & Remote Access in Windows 2008. I checked to see if the "Use default gateway on remote network" was checked or not. It was not checked. –  Jennifer Baker Jun 17 '10 at 0:18
    
Hmmm... the psychic powers don't pay off on this one, then. I'm not 100% clear that I'm understanding your topology, so I'm going to withhold further comment at this time. –  Evan Anderson Jun 17 '10 at 0:35
    
Jennifer -- the default gateway setting that you want to check is on your local PC's VPN connection, not either server. –  Chris_K Jun 17 '10 at 2:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.