Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is there a way to reduce the timeouts for attempting to connect to domain network resources? (Windows Login Authentication, Network Printers, Network Shares, etc.)

I have a series of laptops (Dell latitudes, same hardware) that are being used by roaming staffers that spend half their time onsite and connected to our network through docking stations. When they are connected to the network and they boot their machine it takes 1min 25sec (+/- 10sec) to boot. If I disconnect them from the network it takes anywhere from 4 to six minutes. If I unmount the shares and don't have them automount on boot it takes 4 to 5 minutes. If I uninstall all network printers it cuts the boot time to 3 to 4 minutes. If I boot with a network connection off the domain network but with a vpn connection that autoconnects on boot the boot takes 2 to 3 minutes.

I am assuming that the boot delay is caused by timeouts stacking up relating to trying to connect to network services. I would prefer not to have to delete all my printers and network shares when I leave the network or when shutting down to prevent the slowdown on the subsequent boot off-network.

share|improve this question
    
What version of Windows is on the laptops? –  Zoredache May 30 '09 at 7:59
    
win XP and Vista both –  Tvanover Jun 19 '09 at 22:34

4 Answers 4

up vote 1 down vote accepted

Yes. There is an option for this within group policy. Sorry I can not add links, I am still a new user, but search for the following in using Google.

Slow network connection timeout for user profiles - This will bring up a link to a technet articel on the basic setup of timeout settings.

Windows 2008 Group Policy Reference - This should bring you to a Microsoft site where you can download the guide for the GPO settings in Windows 2008

When making a new GPO Remember to only enable/disable/change on thing at a time. Go back and test. Rinse and Repeat. :-0

Let me know if you want more specific help after looking these over.

Joseph

share|improve this answer
    
We are using Server 2008. –  Tvanover May 29 '09 at 23:09

Try setting this within Group Policy:

Computer Configuration -> Administrative Templates -> System -> Logon

Always wait for the network at computer startup and logon: Disabled
share|improve this answer
    
Unfortunately that impacts when GPO settings are applied even if the computer is always on the network. What I need is to reduce the timeouts, not disable checking completely. –  Tvanover Jun 19 '09 at 22:37

You could try to just disconnect the Ethernet cable while booting and then reconnect once the machine has booted.

share|improve this answer
    
The problem occurs if the network is disconnected. Once I boot it runs fine and if I plug in the cable after boot it then gives access to the network resources just fine. –  Tvanover Jun 1 '09 at 17:47

Do these laptops have wifi on them? Are they using Windows to manage their wireless settings? If yes on both, check how many SSIDs they have listed in their list of preferred networks. Windows will check for each and everyone to find a DC before it times out. If you have say more than 50 in there you'll be waiting for awhile. Removing all of them should speed up login times.

share|improve this answer
    
...and I should have noticed how old this question was –  zippy Aug 15 '09 at 0:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.