Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm adding a new 64-bit server to our domain. Everything seems fine except when accessing the machine using remote desktop, after a few seconds the connection is lost. The error message is "This computer can't connect to the remote computer." "Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator."

A similar result with Telnet on port 3389. I am able to connect but if I hit a key the connection to host lost.

The event log shows the successful login. No errors.

Any ideas?

share|improve this question
    
What client are you connecting from? There's known problems with XP and Vista. –  Chris S Jun 17 '10 at 14:06
    
Have tried disabling Anti-Virus? Are you connecting on the same LAN or through a firewall/IDS/IPS? –  citadelgrad Jun 17 '10 at 14:06
    
I've had the same result from XP SP3, Vista (an older version of remote desktop and recently upgraded to the newest version available), and also from another server that is 64-bit and running windows 2008 Storage OS. Everything is from inside a 1-domain lan. The firewall is disabled on the server and the vista machine. Another odd thing. Sometimes I can login every time I try, other times I get the can't connect error. I need to check anti-virus on the server but I don't remember seeing that. Anti-virus is not running on the other machines. –  mike42 Jun 17 '10 at 14:29

1 Answer 1

Bad NIC. It provided network connectivity but no RDC. NIC 2 works fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.