Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After update to 10.6.4 there's an issue: any new users that I create in Server Prefs/WGM can't post to their blogs, comment, create wiki pages... They can't do anything! There's log from Wiki errors (when user DURAK tries to create new blog entry):

[HTTPChannel,5,127.0.0.1] Traceback (most recent call last):
[HTTPChannel,5,127.0.0.1]   File "/usr/share/caldavd/lib/python/twisted/web/server.py", line 126, in process
self.render(resrc)
[HTTPChannel,5,127.0.0.1]   File "/usr/share/caldavd/lib/python/twisted/web/server.py", line 133, in render
body = resrc.render(self)
[HTTPChannel,5,127.0.0.1]   File "/usr/share/wikid/lib/python/apple_xmlrpc_server/WebAppServer.py", line 90, in render
d = defer.maybeDeferred(function, *args)
[HTTPChannel,5,127.0.0.1]   File "/usr/share/caldavd/lib/python/twisted/internet/defer.py", line 104, in maybeDeferred
result = f(*args, **kw)
[HTTPChannel,5,127.0.0.1] --- <exception caught here> ---
[HTTPChannel,5,127.0.0.1]   File "/usr/share/wikid/lib/python/apple_xmlrpc_server/ContentServiceBase.py", line 121, in xmlrpc_addEntry
aPage = ContentEntry.newBundleBasedContentEntry
(path = path, content = content, author = author, title = title, uid = uid, type = kind, versioned = self.versioned, templateName = template)
[HTTPChannel,5,127.0.0.1]   File "/usr/share/wikid/lib/python/apple_wlt/ContentEntry.py", line 794, in newBundleBasedContentEntry
aPage.save('First created', 'created')
[HTTPChannel,5,127.0.0.1]   File "/usr/share/wikid/lib/python/apple_wlt/ContentEntry.py", line 445, in save
revisions.addRevision(self.serializeEntry(revisionAttributes), inComment = comment, inAuthor = updateAuthor, inChangeType = editType)
[HTTPChannel,5,127.0.0.1]   File "/usr/share/wikid/lib/python/apple_utilities/sqlitersion.py", line 36, in _func
result = f(self, *args, **kwargs)
[HTTPChannel,5,127.0.0.1]   File "/usr/share/wikid/lib/python/apple_utilities/sqlitersion.py", line 49, in addRevision
contentPlistStr = plistlib.writePlistToString(inContentDict).decode("utf-8")
[HTTPChannel,5,127.0.0.1]   File "/S-m/Lib-ry/Fr-ks/Python.fr-k/Ver-s/2.6/lib/pyth-2.6/plistlib.py", line 110, in writePlistToString
[HTTPChannel,5,127.0.0.1]   File "/S-m/Lib-ry/Fr-ks/Python.fr-k/Ver-s/2.6/lib/pyth-2.6/plistlib.py", line 94, in writePlist
[HTTPChannel,5,127.0.0.1]   File "/S-m/Lib-ry/Fr-ks/Python.fr-k/Ver-s/2.6/lib/pyth-2.6/plistlib.py", line 251, in writeValue
[HTTPChannel,5,127.0.0.1]   File "/S-m/Lib-ry/Fr-ks/Python.fr-k/Ver-s/2.6/lib/pyth-2.6/plistlib.py", line 280, in writeDict
[HTTPChannel,5,127.0.0.1]   File "/S-m/Lib-ry/Fr-ks/Python.fr-k/Ver-s/2.6/lib/pyth-2.6/plistlib.py", line 238, in writeValue
[HTTPChannel,5,127.0.0.1]   File "/S-m/Lib-ry/Fr-ks/Python.fr-k/Ver-s/2.6/lib/pyth-2.6/plistlib.py", line 171, in simpleElement
[HTTPChannel,5,127.0.0.1]   File "/S-m/Lib-ry/Fr-ks/Python.fr-k/Ver-s/2.6/lib/pyth-2.6/plistlib.py", line 221, in _escapeAndEncode
[HTTPChannel,5,127.0.0.1] exceptions.UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 0: ordinal not in range(128)
[HTTPChannel,5,127.0.0.1] 'Unparseable html in page, removing whatever was already written.'
[HTTPChannel,5,127.0.0.1] Removing /Library/Collaboration/Users/durak/weblog/27133.page

Any "old" user CAN create, modify, comment, etc. What can you recommend to fix this issue?

Hope for your help...

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Update of Wiki server removed this issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.