Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a couple of severs that used to be Windows Server 2003 that we recently upgraded to Windows Server 2008 R2. A couple of details to set the situation up:

  • We wiped the OS and re-installed.
  • These servers are on one subnet (172.16.x.x) and we are trying to access some file shares on them from another subnet (10.34.x.x).
  • Firewall is disabled on these servers.
  • Trying to access with UNC "\\172.16.x.x\sharename" and net use \\172.16.x.x

However, we're having problems doing this. We are getting "The network path was not found".

Here's some of the things we've tried so far and the result:

  • Tried accessing the share from other (non-2008) servers on the same subnet... Success!
  • Ping servers from different subnet... Success!
  • Telnet connection into port 139 from different subnet... Success!
  • Took a scan through Local Security Policies to see if something obvious needed to be enabled / disabled / configured... Fail

I'm not sure where to look next. I know that the router between the two subnets is locked down pretty good, but this did work for our 2003 servers. Has anything changed in the way of ports used for UNC / file share access in 2008? Maybe I'm missing some security policy setting?

Hoping somebody can take pity on a poor programming guy that can't figure out something really simple. :-)

Thanks!

share|improve this question
    
It, most likely, has something to do with SMB2 and not with being on different subnets. –  MDMarra Jun 17 '10 at 18:30
add comment

1 Answer

up vote 3 down vote accepted

Try checking port 445. That is the port for SMB over TCP in Server 2008.

share|improve this answer
    
Cannot connect... is this a new port not used in 2003? –  Lloyd Cotten Jun 17 '10 at 18:53
    
Nope, that port has been around a while. I suspect you're running into an SMB2 problem, which is more TCP/445 dependent. Your router rules may be getting in the way. –  sysadmin1138 Jun 17 '10 at 19:24
    
Yes opening 445 on the subnet separation firewall worked. –  Lloyd Cotten Jul 8 '10 at 16:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.