Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed Oracle 11g Enterprise Edition on my Windows 7 Pro. My problem is that I cannot log into database from other host (local network).

When I connect to database using Oracle SQLdeveloper everything is ok as long as I specify 'localhost' in connection configuration. However, when I change it to '192.168.0.190' which is my host IP address I get 'The Network Adapter could not establish the connection'. I get the same error when logging in from other host in local network.

What is the problem?

share|improve this question
    
Are you running Windows (or any other) Firewall? –  kmarsh Jun 17 '10 at 19:47
    
No, firewall is disabled. –  Kylo Jun 17 '10 at 20:32
add comment

4 Answers

Is it a firewall issue? Disable (temporarily) the firewall and test.

If it is not a firewall issue then the database listener needs to be configured to run on the proper interface. It is quite likely the default listener is running on the loopback (127.0.0.1) interface and not the external interface (192.168.0.190). Do a search for listener.ora and see what that configuration file contains. Tweak it there to listen on the correct interface.

share|improve this answer
add comment

I wouldn't be remotely surprised if the problem was the zero as third octet, try it was any other number then come back to us.

share|improve this answer
    
I tried 10.1.1.1 but nothing changed. Why do you think it would be such thing? –  Kylo Jun 17 '10 at 20:34
add comment

When you use 127.0.0.1 or localhost, the PC 'knows' that you are talking about it, and it doesn't have to do any lookups. When you use 192.168.0.190, the PC probably sends that off to a router or proxy or something where it will come back to the PC.

My guess is that it isn't coming back.

Do a TELNET 192.168.0.190 1521 and see if you get a connection. If you don't, then it isn't an Oracle database problem, but a networking one. In which case, you should describe your network setup in more detail (is this a home setup, a corporate LAN, DHCP/static IP...)

share|improve this answer
    
Telnet doesn't work. Now I installed this Oracle 11g on VirtualBox with WinXP guest and everything works just fine. I can access it from outside :-) –  Kylo Jun 18 '10 at 21:47
add comment

Are you using DHCP? You'll need to install the Microsoft Loopback Adapter if so.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.