Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using the "ftp" command of linux to send data to a 3rd party provider. This company states that we need to "Disable passive mode in your FTP client", and I confirm it doesn't work in passive mode.

However, when I googled the linux command, I see that the "-p" flag is "the default now for all clients (ftp and pftp) due to security concerns using the PORT transfer mode. The flag is kept for compatibility only and has no effect anymore."

How do I disable passive mode then? And, is it that bad?

share|improve this question

3 Answers 3

up vote 9 down vote accepted

Once you have logged into the site with FTP, type passive and then do your transfer.

share|improve this answer
    
wait I'm confused, typing "passive" would make me go into "active" mode? –  nute Jun 17 '10 at 20:29
2  
It's a boolean trigger. Each issuance of passive (or pasv for old client) flips the active/passive flag. –  sysadmin1138 Jun 17 '10 at 20:30

Just run passive within the client.

Passive mode changes the method used for connecting to the FTP, as active mode often encounters issues with more restrictive firewall rules.

share|improve this answer

in ftp linux commad client type: passive n

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.