Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

how to download and install OpenOffice 3.1 in headless mode on my CentOS server...I am working with a java app that needs OpenOffice as just a service for form generation....I am having a difficult time...any head on what steps to take would be great...

share|improve this question
    
Which CentOS version? –  Massimo Jun 18 '10 at 14:40
    
I have CentOS Linux 5.4 on a VPS box –  CMwilliams Jun 18 '10 at 14:56

3 Answers 3

yum install openoffice.org-headless
share|improve this answer
    
do someone know how to count words openoffice.org ? –  ddjikic Mar 1 '13 at 6:18
yum install openoffice.org-base
yum install openoffice.org-calc
yum install openoffice.org-writer

yum install openoffice.org-headless

You also need the last command to be able to run in headless mode. Otherwise you'll be getting:

/usr/lib64/openoffice.org3/program/soffice.bin X11 error: Can't open display:
   Set DISPLAY environment variable, use -display option
   or check permissions of your X-Server
   (See "man X" resp. "man xhost" for details)
share|improve this answer
    
-headless is no longer necessary (it's now part of the base) –  Kato Dec 29 '12 at 1:07
yum install openoffice.org-<package>

Examples:

yum install openoffice.org-base
yum install openoffice.org-calc
yum install openoffice.org-writer
share|improve this answer
    
each time I attempt to install I keep getting missing dependency errors... –  CMwilliams Jun 18 '10 at 14:06
    
Do I have to install JRE on the server..if so how to the java app I am attempting to set up uses Tomcat6 which is installed and configured...but having difficulty installing OpenOffice in headless mode...not sure what I am missing..thanks a ton –  CMwilliams Jun 18 '10 at 14:08
    
YUM should take care of dependencies automatically... what errors exactly do you get? –  Massimo Jun 18 '10 at 14:39
    
I get quite a few...I can email you them...they are too long for this comment area.. –  CMwilliams Jun 18 '10 at 14:59
    
here are a few... java-gcj-compat is needed by package bsh-1.3.0-9jpp.1.i386 (base) Error: Missing Dependency: java-gcj-compat is needed by package xalan-j2-2.7.0-6jpp.1.i386 (base) Error: Missing Dependency: libhal-storage.so.1 is needed by package gnome-mount-0.5-3.el5.i386 –  CMwilliams Jun 18 '10 at 15:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.