Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been trying to figure out if this is a new "feature" or if there is an issue with my configuration. I'm using Ubuntu 10.04 Desktop with Postfix as MTA. My smtp (as opposed to smtpd) configuration follows that outlined in Jeremy's excellent response here:

http://serverfault.com/questions/119278/configure-postfix-to-send-relay-emails-gmail-smtp-gmail-com-via-port-587

I am able to successfully relay mail through [smtp.gmail.com]:587; however, on the receiving end, the from: address shows: "[my_gmail_username]@gmail.com" instead of "[my_user]@[my_domain]".

Would greatly appreciate any hints or tips; in this instance, my Google skills have failed me!

share|improve this question

4 Answers 4

up vote 4 down vote accepted

I think they've always done this, even when you've configured your gmail to send from other domains. As far as I know, the only way around this is to switch to using Google Apps, which is free if you just use the standard edition. The problem with this is that it means you have to change your MX records so that google handles all of your incoming mail, and it is only free for up to 50 users.

share|improve this answer
    
Ah! This is actually just for a small home server; max 5 users or so. I'll look into this. Probably having Google handle the incoming mail would have some benefits -- I assume they filter and scan on their end, so I don't have to worry about that on my end... In any case, I'm happy to see it's not "just me". –  FromageTheDog Jun 18 '10 at 20:40

Did you add your non gmail address on https://mail.google.com/mail/?shva=1#settings/accounts ? (in the Send mail as part)

share|improve this answer
    
Heh -- I had actually looked into this. Unfortunately, the idea here was to have my local machine serve mail for several users; your suggestion would only work for one user. –  FromageTheDog Jun 18 '10 at 20:38

They do that for security reasons. Your ISP probably uses gmail as they email system, I know mine does. If you want to run a mail server without this issue try smtp2go. It is a small annual cost but it works like a charm! My server has about 5 users and I pay I think about $24.95 a year.

All you need to do is log in to sptp2go and specify what email address are allowed to use the smtp2go smtp server (your email users on your mail server) by email address and then set up your MTA.

SMTP2GO even can runn on different ports. Especially useful if you ISP blocks certain ports.

share|improve this answer
    
I'd looked into this but was stunned at the pricing. There are many established webhosts that will provide far more than just SMTP for $25 a year... –  FromageTheDog Jun 18 '10 at 20:44

I've experienced this as well, and I don't think there's a way around it aside from switching to GAFYD

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.