Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a small network connected with a 16 port unmanaged switch. Recently, the users were complaining about slow network speeds. I checked the switch and noticed that about half the ports were running at half-duplex. In order to try to force the connection to full-duplex, I changed the NIC settings on the PCs from auto-negotiate to 100/full. It didn't seem to help. Still some of the ports have negotiated to half-duplex.

What gives? Is it just time for a new switch?

share|improve this question

8 Answers 8

up vote 13 down vote accepted

I changed the NIC settings on the PCs from auto-negotiate to 100/full. It didn't seem to help. Still some of the ports have negotiated to half-duplex.

If you forced the duplex/speed on a computer then you MUST also force the settings on the switch. In my experience most switches will default to a half-duplex connection. By forcing a duplex setting and disabling auto-negotiation on a computer, you are most likely causing a duplex-mismatch.

Here is a link describing the behavior for Cisco switches. Even Cisco switchs will default to 100/half if the connected computer is forced to 100/full.

If you can't manage the speed/duplex on the switch, then you should set everything to auto. With everything set to auto, if the duplex is not correctly negotiated, you probably should be looking at updating the firmware, contacting the vendor, or replacing the switch.

share|improve this answer
2  
Thanks for the link! I guess I'd better set everything back to auto, then go switch shopping. The entire network runs off this little switch, so I don't like the idea of it being a consumer model. It's time to upgrade. –  user5921 May 30 '09 at 15:54

There is no good reason to suffer with half duplex. :)

It sounds like the switch is inadequate for your needs. In my (admittedly limited) experience, cheap consumer-grade switches (even from "name" brands) cannot run at the full capacity implied by their number of ports and advertised speeds.

Do you have another switch you could try in this one's place? Is it always the same ports that are failing? Always the same clients?

It isn't difficult to get a decent 24-port managed switch for $150-500.

share|improve this answer

An unmanaged switch needs the clients to be configured at auto/auto (speed/duplex) unless the manual calls for something different (which is extremely rare these days). If the switch and clients are both rated at 100mbit/full but are negotiating at something lower, then you have a problem.

I would start first by moving the clients between ports to see if the problem travels between ports or stays at a particular port. If it stays, then the switch port is bad.

If the problem travels, then try replacing the cable or putting a different client on the cable to see where the problem is.

If the above troubleshooting ends up with random results then you are back to a bad switch or you have some external interference (like cable running over fluorescent light ballasts).

share|improve this answer

I would try troubleshooting the connections by unplugging all cables from the switch, except for one that is negotiating to half duplex. See if the link is able to increase to full duplex. If it doesn't increase, try switching ports and power cycling the switch and the PC.

Have you tried bringing the switch into the same room as the PC and connecting with a short, high-quality ethernet cable?

share|improve this answer

The other answers are good ones, but here's the simple rule to remember:

They have to match. Either set BOTH sides to auto, or hard-code BOTH sides to full/100.

The general trend is for "user-facing" ports, like the wall-jacks in a cubicle or conference room, to be auto, and "infrastructure" ports, like connecting to servers and routers in the data center, to be hard-coded. As mentioned above - with an unmanaged switch like yours, it's almost certainly set to auto-negotiate all ports, particularly if it's officially labeled "10/100"

share|improve this answer

Depends upon the switch, the NIC's and the OS being used.

Sometimes it's best to nail the port configs at the switch. Various vendors implement auto-neg differently and not all NICs will play nice. Might be interesting to check what's connected to the ports that stay half-duplex. They might be a different brand to the ones that go full-duplex.

Different patch levels of Windows can sometimes cause problems as well.

share|improve this answer

Use Auto. If you force full duplex and the switch doesn't support it, you'll get a lot of late collisions on that link, which will slow you down. If you suspect problems you can try forcing half-duplex on all clients/ports, which means each link only works in one direction at a time.

Auto-detecting ports often choose wrongly when the other end can only do 10Mbps Half Duplex. If you have such beasts, then make sure the other end knows it, ie forced 10Mbps HD to match.

share|improve this answer

Try replacing or swapping round the cables. If the cable is cracked and noisy, autonegotiation may back off.

Some network card / switch combinations don't autonegotiate successfully; I had trouble with a cheap realtek card which could consistently crash an HP switch. Is it consistently some machines that have the problem?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.