Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have worked on Linux for a year. One thing bothers me is that I am not familar with the process of installing new software with source code(I can't install them from netword due to environment limitations).

I was often blocked with different kinds of error, for example:

libtool: install: error: relink `Magick++/lib/' with the above command before installing it


magick/.libs/ undefined reference to `gzseek64'
magick/.libs/ undefined reference to `gztell64'

Though I finally found solution with google, I don't know exactly why it works.

Can anyone helps me with this situation or give me some advice on how to improve myself on such kind of things?

I am lack of the knowledage of "configure","make","difference of 64bit","shared lib"; Could anyone point me in the right direction and give me some helpful books or articles?

Thanks in advance!

share|improve this question
Are you installing magick++? I needed to install magick++ for MediaWiki and I ran into those issues. I can't exactly remember what errors I got but it was relating to some missing – Nikolas Sakic Jun 20 '10 at 6:44
Yes, I met those errors while installing imagemagick; I finally made it work, however I don't know why that works:) – bluesea007 Jun 20 '10 at 7:59

1 Answer 1

I suggest you take the specific issues to the respective authors/communities of the software packages you are dealing with, try to resolve them there, and learn from those experiences.

While there is various literature around to learn about "Linux", issues like in your examples are quite specific and can't really be learned a priori.

share|improve this answer
Thanks a lot for your advice:) I should learn more about "Linux":) – bluesea007 Jun 20 '10 at 8:00
If you're interested in learning more about linux, then you could check out the StackExchange network's linux site: – Kevin M Nov 20 '10 at 20:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.