Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

After a recent update (Xorg was updated among other things), GTK apps stopped running in my kde4. I have a Debian unstable, updated around 22 April. When I try to run them I get the following error:

ga@grzes:~$ iceweasel 
The program 'firefox-bin' received an X Window System error. 
This probably reflects a bug in the program. 
The error was 'BadName (named color or font does not exist)'. 
  (Details: serial 888 error_code 15 request_code 45 minor_code 0) 
  (Note to programmers: normally, X errors are reported asynchronously; 
   that is, you will receive the error a while after causing it. 
   To debug your program, run it with the --sync command line 
   option to change this behavior. You can then get a meaningful 
   backtrace from your debugger if you break on the gdk_x_error() function.) 
ga@grzes:~$ gimp The program 'gimp' received an X Window 
System error. 
This probably reflects a bug in the program. 
The error was 'BadName (named color or font does not exist)'. 
  (Details: serial 6955 error_code 15 request_code 45 minor_code 0) 
  (Note to programmers: normally, X errors are reported asynchronously; 
   that is, you will receive the error a while after causing it. 
   To debug your program, run it with the --sync command line 
   option to change this behavior. You can then get a meaningful 
   backtrace from your debugger if you break on the gdk_x_error() function.) 


(script-fu:4643): LibGimpBase-WARNING **: script-fu: gimp_wire_read(): 
error

I have to restart the font server manually to have it fixed:

ga@grzes:~$ su 
Password: 
grzes:/home/ga# /etc/init.d/xfs restart 
Stopping X font server: xfs. 
Setting up X font server socket directory /tmp/.font-unix...done. 
Starting X font server: xfs.

Any ideas what could be wrong? Is it a configuration issue? My system has been updated for the last 7 years, so I can have some old settings.

EDIT: I would be grateful if someone could point me to a relevant discussion list or bugzilla site, because I am stuck with this problem.

share|improve this question

4 Answers 4

up vote 2 down vote accepted
+100

As far as I am aware the x11 font server is now all but deprecated in favor of client side fonts. Ubuntu certainly doesn't use xfs any more (unless you specifically install it) and I doubt that Debian Unstable installs it by default either.

After booting up, rather than restarting xfs, try stopping it. If everything continues to work as expected then just uninstall it.

share|improve this answer
    
worked like a dream, cheers! –  Grzenio May 6 '09 at 21:54

Sounds like it could be this known bug in Xorg 1.5:

I would be grateful if someone could point me to a relevant discussion list or bugzilla site, because I am stuck with this problem.

Xorg bugzilla: http://bugs.freedesktop.org - use the product "xorg"

Xorg mailing list: http://lists.freedesktop.org/mailman/listinfo/xorg

share|improve this answer

Try running xlsfonts before and after the xfs restart, and comparing the results. The differences could be very telling!

share|improve this answer
    
I will remember after the next reboot. But why do I need to restart xfs? I checked that it is running after reboot. –  Grzenio Apr 30 '09 at 19:44
1  
Restarting it makes it reload the fonts (and more importantly, the font path). It may be that the list of available fonts is different when your system first starts up. –  Chris Jester-Young Apr 30 '09 at 19:48
    
I just checked the number of listed fonts and its the same: ga@grzes:~$ xlsfonts | sed -n '$=' 18780 ga@grzes:~$ su Password: grzes:/home/ga# /etc/init.d/xfs restart Stopping X font server: xfs. Setting up X font server socket directory /tmp/.font-unix...done. Starting X font server: xfs. grzes:/home/ga# exit ga@grzes:~$ xlsfonts | sed -n '$=' 18780 –  Grzenio Apr 30 '09 at 20:23

Find the simplest program you can run that will give you this error, and run it under ltrace to narrow down what exact call is causing the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.