Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The title says it all. I need Tomcat's webdav servlet to create files with rw-rw-r-- rights, but it keeps creating it as rw-r--r--. I tried to set up umask in /etc/profile, but it didn't help (although manualy created new files has desired permission settings). According to /etc/passwd the user that runs Tomcat has /etc/false as shell and has no bashrc in his home directory. The host os is Debian.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

While this is completely a hack, open up tomcat/bin/startup.sh and set 'umask 0002' in it. You could also do this in catalina.sh, you get the idea - you could even find right where java launches in catalina.sh (search for "catalina.out") and put it directly above that logic block to ensure it's effective when java is let loose on your poor CPU.

share|improve this answer
1  
I have found out that the umask is actually set in the init.d script (that's why setting it in /etc/profile didn't help). So I simply changed that line in /etc/init.d/tomcat6 script and it worked. –  calavera.info Jun 30 '10 at 14:44
1  
Yah - the issue is that there's no standard for Tomcat/JBoss SysV startup, everyone rolls their own. Glad you found out for your situation and did the right thing. –  troyengel Jul 5 '10 at 7:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.