Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just set up Poptop on our Ubuntu 10.04 server so we could use it as a VPN.

I can connect to the LAN through PPTP but I can't use it a gateway (I needed to uncheck the "use default gateway on remote network" option on the Network Adapter properties in Windows.

We don't actually need (nor want) to to route all internet but there is certain stuff that is restricted to our office network's IP address such as SFTP access to hosted web servers.

Most of my settings is default except that I'm using the same subnet as our LAN. I've also enabled ip forwarding in sysctl.

How can I use it as default gateway?

share|improve this question
    
You'll probably need to start by renumbering something so you don't have the same subnet in 2 places. –  Zoredache Jun 22 '10 at 5:29
    
But I want them to be in the same subnet. For the ip range 192.168.0.xyz, we reserve under 100 for static IPs, DHCP to use between 100-200, and I've set up Poptop to be on 192.168.168.210-220 with its localip as 192.168.0.7 (the ip of the server). –  wag2639 Jun 22 '10 at 7:04
    
Okay - Rule #101 your local network, and your remote network, cannot have overlapping subnets, and work as your expect it to work. Just a point to note - if your using smart switches or managed switches, then the problems of having large subnets are significantly reduced. (unless you have a rouge hub somewhere!) –  Mister IT Guru Feb 23 '11 at 15:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.