Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have tried to install a lamp sever on my ubuntu 10.04 (home) installation by typing this into the terminal:

sudo apt-get install lamp-server^

However, afterwards, when I point my browser towards http://localhost I geta 403 Forbidden error. I tried multiple times to change the permissions of the /var/www/ folder by right clicking it and setting the permissions to read and write for my user, but it just goes back to what it was after I close the options window.

HELP

share|improve this question
    
What do you expect instead of the error 403 when loading http://localhost/? Have you placed any files into the directory /var/www/? –  joschi Jun 23 '10 at 7:54

3 Answers 3

Take a look at the chapter about Apache httpd in the Ubuntu Server Guide. It describes the setup fairly well and should answer your questions.

The error 403 when browsing http://localhost/ suggests that there is no index.html in /var/www and that Options +Indexes is not set.

share|improve this answer

LAMP Setup try above link its work

share|improve this answer

I think you want to use tasksel instead for the package.

sudo tasksel install lamp-server

Then check if your apache is running with the following:

sudo /etc/init.d/apache2 status

More docs to read here: https://help.ubuntu.com/10.04/serverguide/C/httpd.html

share|improve this answer
    
apt-get install lamp-server^ is the same as tasksel install lamp-server. Just look at the output of tasksel -t install lamp-server. –  joschi Jun 23 '10 at 7:52
    
Those were the instructions from the Ubuntu Community help page: help.ubuntu.com/community/ApacheMySQLPHP –  wag2639 Jun 23 '10 at 13:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.