Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got an open case with Dell, but I wanted to throw this out here. Brand new PE T610, PERC H200 controller, 32GB of memory

I've got 8 drives in it currently. 2x 146GB and 6x 500GB. The first 4 drives are on the first channel, the last 4 on the second. When I first booted it up, I created a RAID 1 in the SAS on the 2 146GB and left the rest of the drives alone. Booted from my Server 2k8 R2 64 bit disk and I'm able to install the OS with no issues.

Here's the weird part. If i use the Openmanage software to create the RAID 10 array with the 6 remaining disks, the server pulls a BSoD. Rebooting prompts a startup repair, which is unable to continue. Removing the array in the SAS BIOS config has no effect.

Delete all arrays, re-create the initial mirror and install the OS the same. But now, shut down and create the RAID 10 in the SAS BIOS. Upon a reboot, i get the startup repair again.

All firmware is up to date, Dell diagnostics come back clean.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Which drivers are you using for the controller? Windows or Dell?

share|improve this answer
    
Windows drivers so far, I'm currently doing a fresh build, and will use the Dell ones. –  DanBig Jun 22 '10 at 17:58
    
Keep us posted. –  joeqwerty Jun 22 '10 at 18:27
    
Well, this was it. It was last on my list of things to try, mainly because the LSI driver that Windows used was only a couple months old, while the Dell driver was from Dec of last year. I wrongly assumed newer was better. –  DanBig Jun 22 '10 at 20:28
    
Glad you got it worked out. Why is it always the last thing you try that gets it working? (Because then you stop trying things). ;) –  joeqwerty Jun 22 '10 at 20:44

I've not worked with the PERC H200 yet, but previous generations of the PERC line have been OEM'ed versions of LSILogic MegaRaid cards. As such, the MegaCLI tools from LSILogic will work to get a lower-level view of the situation than OMSA exposes in the gui. You might also try creating your logical array via the cli; perhaps there's a problem in Openmanage.

I like the Perc Cheat Sheet as a good starting point for working with MegaCLI.

share|improve this answer

Have you set the preferred boot device?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.